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1 Getting Started
We’ve designed AnyRail™ to be as straightforward as possible. You can start experimenting with layouts as

soon as you’ve installed the software. However, it’s probably a good idea to read through this Getting Started

guide.

1.1 Setting up
The Settings tab enables you to set up AnyRail to suit your way of working. Most of the default settings

should be OK for now. However, you probably want to choose a measurement system and specify a work

area right away.

1.1.1 Choosing a measurement system
By default, all measurements are metric. However, you can change this.

To specify a measurement system 

1. Click the Settings tab:

2. Click Measurement system:

If you select English fractional units , AnyRail shows all measurements using fractions, e.g. 20 ¾. If you select

English decimal units , the same value appears as 20.75. AnyRail accepts measurements in both formats.

1.1.2 Specifying a work area size
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In AnyRail, you can set the outer limits of your work area.

To specify a work area size 

1. Click the Settings tab.

2. Find the Work Area group:

3. Enter a Length and Width.

1.1.3 Creating a table top
For indoor layouts, you’ll probably want to draw a train table.

To add a table top 

1. Open the Insert tab and find the Table top group:

2. Click Template:

3. Select a template, change the values to match the desired dimensions, and click OK.

TIP: Use the Position coordinates to put the lef t top corner of the table top in a certain location.
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The table top appears on the work area.

NOTE: Make sure the work area is large enough to contain the table top.

TIP: If none of the templates fits your needs, you can use the Free form  function.

1.1.4 View drawing scale
This is roughly the scale at which things are displayed on screen. This is not to be confused with your

modeling scale.

Don’t rely on this for precise measurements, as the actual sizes depend on the size of your monitor.

To zoom in or zoom out 

For fast zoom, press CTRL and use the mouse wheel.

Or:

1. Locate the View Scale slider in the lower right corner:
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2. Move the slider to change the view scale.

Or:

1. Click the Home tab.

2. Select a View Scale.

When you set the view scale to 1:10, one centimeter in the plan represents 10 about centimeters in reality.

However, this does not take into account your real screen size.

TIP: To quickly zoom, press CTRL and use the mouse wheel.

TIP: To zoom using the keyboard, press CTRL + or CTRL -.

NOTE: This setting has nothing to do with the train scale i.e.: TT, O, H0, etc. The train scale depends on

which track library you use.

1.2 Track Libraries
The first thing you need is some track!

AnyRail keeps track in libraries, and has one for all the well-known manufacturers, including Atlas, Märklin,

Lionel, Roco, Peco, and many others. Each piece of track matches the original as closely as possible - some of

them were even created using the manufacturer’s original CAD files.

1.2.1 Opening a track library

To open a Track Library 

1. Click the Track libraries tab:
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You’ll see a group for each scale.

2. Click the name of the manufacturer to open the list of track libraries.

3. Select a track library:

You can have as many libraries open as you want. Don’t worry, AnyRail won’t link incompatible track pieces –

unless you tell it to (see The AnyRail Settings Tab).

TIP: To open all the libraries used in a plan at once, click Open used libraries on the Home tab.

1.2.2 Browsing a track library

To browse a track library 

The status bar at the bottom of the screen shows detailed information about the track.
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1. Hover the mouse over the track to see the tooltip.

2. You’ll see the full information in the status bar.

1.2.3 Closing a track library

To close a Track Library 

Click the little cross in the right upper corner of the track window:

NOTE: You can also close a library the same way you opened it.

1.3 Docking and undocking a library window
Drag the Library window around like any other window. You can also dock it. This means that it will stop

floating and stick to the edge of the main window.

To dock a Library window 

Drag the library onto one of the docking stickers:
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TIP: To avoid docking, hold down CTRL while you move the library.

To undock a Library window 

Drag the library by the title bar to undock:

Nesting libraries 
Nest a library by dropping it onto the title bar of another library. Use the tabs to switch libraries:
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TIP: To un-nest a library, drag it away by its tab.

1.4 Working with track
AnyRail is designed to make working with track quick and easy.

1.4.1 Adding track

To add a track Piece 

There are three methods for adding new track:

Method 1: Click 

Click the track and the piece appears on the work area:
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Method 2: Drag and drop 

Drag the piece from the library onto the work area:

Method 3: SHIFT-click to connect to the most recently added component 

Click piece while holding down the SHIFT key, and the new part automatically connects to the most

recently added part:
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TIP: To undo the most recent action, click the Undo button, or press Ctrl-Z.

1.4.2 Track appearance
A few general settings control how track appears on your screen. You can find these in the ribbon Show tab:

Select between the dif ferent styles.

Example 1: Centerline 

Example 2: Track 
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Example 3: Detailed 

NOTE: AnyRail displays sleepers for aesthetic reasons, only. The position shown is not intended to be

exact, though the width is correct.

Example 4: Centerline with roadbed 

NOTE: To avoid disappointment, use this option to check that the roadbed fits on your train table and

that the tracks are not too close to each other. Of course you also have to take into account the width of

the trains and the necessary extra clearance in curves.

1.4.3 Track build style
Track can have dif ferent build styles. This influences the drawing in 2D, but also in 3D.

Select the track first, so the Track tab appears.

Standard 

The track is displayed as-is, both in 2D and 3D.

Hidden 

The track is displayed as a dotted line in 2D. In 3D, it will be hidden, and a tunnel is created if necessary.
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Embankment 

In 2D, small lines indicate that the track is on an embankment. In 3D, the ground is shaped as an

embankment.

Bridge 

In 2D, trellis is drawn over the bridge. In 3D, the track is put on pillars.

1.4.4 Moving and connecting track
Use the mouse to move and connect your track pieces. By default, only track from the same track system can

be connected. However, you can override this (see The AnyRail Settings Tab).

To connect track 
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1. Drag the track close to the target. Blue dots appear to indicate the endpoints that will connect.

2. Release the mouse button. A circle marks the connection point.

AnyRail will shif t and rotate the track to create a perfect connection.

1.4.5 Disconnecting track
You can disconnect track using the popup menu or the ribbon.

To disconnect an endpoint using the popup menu 

Right-click the connection and select Disconnect.

The track does not move, but the connection disappears.

To disconnect an endpoint using the ribbon 

1. Click the connection to select it.

The Connection tab opens automatically.

2. Click Disconnect on the Connection tab.

TIP: You can also press DEL on the keyboard to remove a selected connection.
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To disconnect the track using the popup menu 

Right-click the track and select Disconnect.

To disconnect the track using the ribbon 

1. Click the track to select it.

The Track tab appears automatically.

2. Click Disconnect.

1.4.6 Selecting track
Obviously, you can select one section of track by simply clicking it.

However, you can also use the mouse to select several pieces of track, and then move or alter them as one.

To select track 
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Hold down the lef t mouse button and draw a box to select multiple pieces.

Selected track is highlighted in bold green.

Drag one to drag them all.

Use the handle to rotate the selection.

Depending on what you’ve selected, extra tabs appear on the ribbon.

Other ways to select or deselect pieces 
17



CTRL + click each piece 

CTRL-click to add or remove a part to the selection.

Double-click a piece to extend the selection 

Double click to extend the selection in a logical manner.

Triple-click to select all connected track 

SHIFT-click to extend the selection 

Before:

SHIFT-click to select the route from an already selected part to here.

After:
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The shortest route is selected.

To deselect a single piece 

CTRL-click the piece.

To deselect all the pieces 

Press ESC.

NOTE: You can also copy, paste and delete track in the standard Windows way.

TIP: If you open AnyRail twice, you can copy and paste elements from one layout to the other.

1.4.7 Gluing track
If you want to make sure that you don’t accidentally move track, you can glue it down!

To glue track 

Method 1: 

Right-click the track and select Glue.

Method 2: 
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Click the track to select it, then click Glue on the ribbon.

If you want to know whether track is glued, hover over it, and look in the status bar:

The status bar shows a glue pot whenever you hover over glued track.

1.4.8 Turntables
Many turntables require a special adapter or transition track from the same library in order to connect them

to the regular tracks at the required angles.

Adapter track is used. Full information on a track element is always on the status bar when you hover it.

1.4.9 Closing gaps
If you use sectional track, you’ll of ten find that it’s dif ficult to make a perfect fit when your design becomes

more complex.

Some manufacturers provide all sorts of filler track just for this purpose.

Sometimes you can make the track fit by using the play (wiggle room) in the track. While this can be

considered cheating, sometimes you don’t even notice that you’re doing just that when laying real track.

In AnyRail, you can cheat a little bit as well.
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In general, to close a small gap, you can often disconnect a stretch of track and rotate it one or two degrees

to make your plan fit.

To close a gap 

1. Switch of f Autoconnect in the Settings tab. When you do that, track will no longer jump into position,

but will be lef t just where you dropped it. If there is another piece of track within the Distance (defined

in the Settings tab, under Autoconnect) a connection will be made to it.

2. Disconnect a stretch of track and rotate it one or two degrees so it will fit.

3. Put the track back in place and make sure to connect the outer ends.

4. Turn Autoconnect back on.

NOTE: Only resort to this technique after you’ve tried to make your track plan fit properly.

1.4.10 Creating a helix
A Helix is a corkscrew made from track, with the purpose of bringing trains to another level of your layout.

In AnyRail, they’re easy to generate from a single curve.

To create a helix 

1. Right-click a single, unconnected curve of your choice. This can be a piece of flex, af ter you’ve used the

curve flex function.

2. Select Create helix… .
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3. Enter the required values.

AnyRail displays the slope and the height clearance for the values entered.

4. Click OK.

5. To get an impression of the result, use the 3D view from the Home tab:

1.5 Flex track
Many sectional track manufacturers also provide flex track. Flex track can be used to fill gaps. Its looser

curves also give your layout a more natural look.

1.5.1 Basic Handling
Some libraries contain flex track, designed to be bent, stretched and trimmed. You can do this to AnyRail flex

track by using the control points. These are the little crosses that appear at either end of a piece, and on

either side of it. Dragging the control point changes the track.

AnyRail checks the track as you shape it and paints it red if:
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You over-stretch it

You bend it into overly tight curves (likely to derail a train)

NOTE : Of course, these features can be switched off.

To connect flex track 

Connect flex track in the usual way by dragging it near another part.

Or:

Drag one of the outer control points onto another endpoint.

…and release.

AnyRail smoothes out the curves of the resulting track.

TIP: Pressing SHIFT while dragging a control point keeps it in a straight line.

1.5.2 Curves, straights and easements from flex
AnyRail can create (near) perfect arcs, easements and straights from flex track.

To create a straight, curve or easement 

Right-click the flex and select Straight flex… , Curve flex… or Easement flex… .
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Alternatively:

Click the flex, and select from the ribbon.

A straight 

Set the length.

A curve 

Creating a precise curve (circular arc) is similar to straightening a piece of track.

Set the angle and the radius of the curve.
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An easement 

An easement provides a smooth transition between a straight and a curve. Real railways always use them to

avoid wear and tear, and to permit higher speeds. They also increase passenger comfort.

Set the angle and the radius of the easement. Don’t forget to indicate whether it’s a lef t or right

easement.

1.5.3 Parallel flex track
AnyRail can create parallel flex track.

To create parallel track 

1. Right-click the flex track and select Add parallel flex… .
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2. In the dialog box, set a Distance and a position for the new flex track.

3. Click OK to see the result.
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1.6 The ribbon and the popup menu

The ribbon 

When you select something, the ribbon shows you what you can do with it and grays out any options that

don’t apply.

Example 1: Select a flex 

A piece of track is selected. The Track tab opens.

Example 2: Select a flex, a surface, and some text 

The track, the surface, and the text are selected. A tab for each appears. A fourth tab appears for functions

that apply to the selection as a whole. A fif th tab provides grouping functions.

The popup menu 

A handy feature of AnyRail is the menu that “pops up” with relevant options whenever you right-click

something.

Example 1: Right-click a stretch of track 

Right-click to open the popup menu.
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Options that don’t apply to the selection are grayed out.

Example 2: Right-click a connection 

Right-click to open the popup menu.

There’s a description of each option in the Reference guide. The next couple of chapters cover the more

commonly used ones.

1.7 Pieces, stretches and sections
AnyRail thinks of your track as being made up of pieces, stretches and sections.

Pieces and stretches 

A piece of track is just that – any one of the components you select from the Track Libraries. A stretch of

track is a piece and all pieces connected to it. Many AnyRail options apply to stretches rather than pieces. A

section of track is something that you create, and requires more explanation.
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In orange is a color coded section.

Sections 

A section is a stretch of track with a specific function or purpose, as defined by you. You can turn any stretch

– that is a connected group of pieces - into a section, as long as both ends have an isolator.

Sections are useful in both conventional and digital operation:

In conventional (analog) operation, you need to feed stretches of track individually to control trains

independently of each other. This enables you, e.g., to switch of f a section’s power to stop a train for a

red signal.

In digital operation, especially with a PC, it is of ten handy to know where trains are so that the software

can control them. Usually, the layout is divided into sections of track, each with its own occupancy

detector. The shorter the sections, the more accurate the positional information.

NOTE: Once you’ve created a section, you can change its properties such as color, name and usage. You

can also see a list of sections. This is helpful when calculating how many occupancy detectors you need.

1.7.1 Working with sections
Here are the two methods for creating a section.

Method 1: Creating a section from selected track 

1. Select the track for the section.
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2. Right-click the selected track and click Create section. Or just click Create section on the ribbon.

Method 2: Creating a section from isolated track 

1. Right-click and isolate each connection.

A triangle indicates an isolated connection.

A natural endpoint does not require an isolator.

2. Right-click within the isolated tracks and select Create section.

The newly created section changes color:
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TIP: Of course, you can also use the ribbon to create the section. Left-click one piece of track within the

isolated tracks to select it, and click Create Section in the ribbon.

To change a section’s properties 

1. Left-click a piece of track in the section.

The ribbon opens the Track tab with a Section group:

2. Select or enter a Description and enter a Name.

The name appears on the layout.

The software tries to find the best way to position the text.

To change a section’s color 

1. In the ribbon Track tab, Section group, select Color.

A selection of colors appears. Click More colors…  for more choices.

2. Select a color.

The section changes color.

1.8 Working with height
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Few model railway layouts are entirely on the same level. Fortunately, AnyRail can handle track at varying

heights.

If you want to make sure that the height of a certain point is not changed accidentally, right-click it, and

select Lock height.

The point turns blue and yellow to indicate that its height is locked:

When the height is locked, the connection is colored blue and yellow, and drawn as a diamond. Also, a lock

is shown in the status bar when hovered.

1.8.1 Displaying heights
Before working with heights, it helps to switch on their display.

To display heights 

1. In the ribbon Show tab, find the Info group:

2. Tick Slope percentages and Height.

Heights and slopes now appear on the track:

1.8.2 Specifying heights
There are various ways to create a slope, or set the height of track.

As it can be on a slope, a piece of track doesn’t necessarily have a single height. AnyRail works out the height

based on the track’s endpoints and connections.

You can specify a certain height for a stretch of track, and then ease the connected track into sensible

gradients.

AnyRail will show a warning if slopes are too steep.
32



TIP: If your tracks cross, make sure you leave enough headroom for the lower train, and any possible

overhead lines! Bear in mind the thickness of the tracks, the sleepers, and the actual bridge.

To set selected track to a certain height 

1. Right-click the selected track, and click Set height… .

Or just click Set height…  on the ribbon.

2. Enter a value for the height.

AnyRail has set the height to the given value.

NOTE: Steep gradients are displayed in red.

To specify a height for a point 
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This function is useful when you want to set the height of an individual point.

Click the point (this is an endpoint or a connection), and set the Height on the ribbon.

To create a slope 

This function creates a slope starting from a connection or an endpoint.

1. Right-click the point (this is an endpoint or connection), and select Create slope….

2. Enter heights for startpoint, endpoint and slope percentage. Select the direction in which to create the

slope from this connection.

AnyRail created the slope:

To create a smooth slope 

Sometimes, it’s useful to create a slope between two points, where AnyRail calculates a linear descent

percentage. This is called a smooth slope.

There are a few restrictions when creating a slope from point A to point B.
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All the track on the slope should be connected.

There should be only one ‘path’ from A to B.

The path may go through turnouts and crossings, but the path may not split to a third point.

NOTE: This feature works best when A and B have a dif ferent height!

Example 

The height of point A is 0. The Height of point B is set to 5.

1. Select the stretch for which you want a smooth slope.

2. Click Smooth slope to create a linear slope.

The height at each point is calculated to make a smooth slope:

Too steep slopes are displayed in red.

To set the maximum percentage for slopes 

All gradients exceeding this value are displayed in red.

1. Open the ribbon Settings, and locate Slopes.
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2. Set Maximum %.

1.9 The status bar
There’s a lot to keep track of if you use all of AnyRail’s features. The good news is that the status bar is a

mine of information:

See below for the meaning of each field.

To customize the status bar 

Right-click the status bar to change the active fields.

1.10 More than just track
Being enthusiasts ourselves, we suspect that your layout will contain more than just track!

For this reason, AnyRail enables you to draw shapes onto your layout to represent scenery, such as stations

or landscape features.

Of course, you can draw your train table or your garden.

You can also mark track as hidden, and add text labels and position them as required.

Additionally there are plenty of predefined elements.
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1.10.1 Adding lines and surfaces

To add a line 

1. Open the Insert tab.

2. Click Add line.
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3. Click for each point on the line.

4. Double click to finalize.

TIP: You can also right-click on the work area, and select Add line from the popup menu.

To add a surface 

1. Open the Insert tab.

2. Click Add surface.

3. Click for each corner.

4. Double click to finalize.

TIP: You can also right-click on the work area, and select Add surface from the popup menu.

To add a point to the line or surface 
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1. Right-click where you want to add a point.

2. Select Add point.

A new point is added.

TIP: You can add a point by hovering over the line and pressing ‘p’.

To delete a point 

1. Right-click the point.

2. Select Delete point.

TIP: To quickly delete a point, click it and press Delete.

To move a point 

Simply drag the point to move it.

To position a point 

Sometimes you need to precisely position a point.
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1. Click the point to activate it.

2. Enter the precise x and y position.

To create round corners 

You can create round or curved corners for points that have neighboring points. The points at the end of the

line cannot be set to round or curved.

A Round corner is a perfect arc. A part of a circle.

A Curved corner is a curve halfway to each neighboring point.

1.10.2 Manipulating surfaces
This topic covers a few special functions for surfaces.

To move a line 
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1. Hover on a line and press SHIFT. The line becomes bold.

2. Drag the line while holding down SHIFT to change the shape.

To resize the shape 

1. Hover on a point and press SHIFT. All the shape’s points light up…

2. Drag the point to enlarge or shrink the shape.

1.10.3 Adding text
You can place text anywhere on your layout plan, for example to label features or make notes to yourself.

To add text 
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1. Find the ribbon Insert tab, and click Add Text.

2. Click in the work area.

3. Enter your text and press Enter.

NOTE: Depending on the scale of your drawing, the initial text may be very small. To change the size,

lef t-click the text, and set the size in the ribbon.

NOTE: To create a newline, use SHIFT-Enter.

To change the appearance 

Left-click on the text and select one of the options from the ribbon Text tab.

To edit existing text 

Double-click the text.

To move the text 

Place the cursor on the text, lef t-click and hold to drag the text.

You can also add names to sections of track. See Working with Sections.

1.10.4 Adding rulers

To add a ruler 

1. Find the Insert tab, and click Add Ruler.

2. Click in the work area.

3. Size the ruler by dragging its end points.

To change the appearance 

Left-click on the ruler and select one of the options from the ribbon Rulers tab.

To move the ruler 

Place the cursor on the ruler, lef t-click and hold to drag the ruler.

1.10.5 Predefined elements
AnyRail has a number of predefined elements that you can find in the Object libraries tab.

These include:

Scenery elements 
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Signals 

Structures 

1.10.6 Groups
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You can combine lines, surfaces and text into a Group. Other types of elements cannot be grouped.

To create a group 

1. Select all the elements that should form the group.

2. Open the Groups tab that appears.

3. Click Group.

NOTE: Track cannot be grouped.

1.11 Layers
AnyRail layers let you show or hide dif ferent parts of your layout plan while you’re working on it, e.g. to

hide scenery while working on track.

It’s up to you how to arrange them. A layer can contain all sorts of elements, on all heights. (Really, a layer is

just an arbitrary group of elements.)

There is always one active layer. This layer is always visible. New elements are always added to the ative

layer.

1.11.1 The Layers pane
Maintain your layers using the Layers pane.

From this pane, you can add, delete, and rename layers. You can also pick which layers are visible.

To add a layer 

1. Navigate to the Home tab.

2. Click Layers.

3. Click Add layer.

To remove a layer 

In the layers pane, click the little red cross to delete a layer.
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CAUTION: Deleting a layer deletes all the elements it contains! If you press Delete layer by accident, you

can always use Undo (Ctrl-Z).

To rename a layer 

In the layers pane, double click the layer name so you can edit it.

NOTE: AnyRail makes sure that each layer has a unique name.

To make a layer visible or invisible 

In the layers pane, click the lamp in front of the layer name.

NOTE: You cannot make the active layer invisible.

To lock a layer 

In the layers pane, click the padlock in front of the layer name.

NOTE: You cannot lock the current layer.

NOTE: The active layer is bold and has a green background.

TIP: Click a layer name to make it the active layer.

1.11.2 Moving objects to another layer
Of course, it might happen that you decide to move something to another layer. That’s easy.

To move objects to another layer 

1. Select the objects.

2. In the ribbon, select the target layer.

Example 
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1.12 3D Viewer
AnyRail provides a way to get a 3D impression of your design.

To go to the 3D View 

Click 3D View on the Home tab.

1.12.1 Navigating
The 3D viewer provides two dif ferent cameras.

Standard camera 
This camera allows you to quickly go around the layout using the mouse only.

The camera is aimed at one point, initially at the center of your layout, the pivot point.

To navigate 

Use the mouse wheel to zoom in and out
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Hold down the lef t mouse button and move the mouse to move around the focal point. The pivot point

remains the same.

Hold down the right mouse button and move the mouse to pan. This changes the pivot point.

FPS camera 
This camera works much like the camera in a First person shooter type of game. You can move around, and

just get to see whatever you look at. You need to use the mouse and the arrow keys on your keyboard.

To navigate 

Hold down the lef t mouse button and move the mouse to change the viewing direction.

Use the arrow keys to move forward, backwards, and sideways. Hold down the right mouse button to

double your speed.

Tip: In case you get lost, click the Camera back to starting point button.

1.12.2 Lights
You can change the lights for the scene.

There is a light at each corner, a top light, and ambient light.

Move sliders to change the light.

1.12.3 Snapshot
You can take a snapshot of the 3D view at any time.

To make a snapshot 

Click the snapshot button.
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1.13 User objects
You can save your creation as a user object for later reuse. You can even share user objects with other

AnyRail users.

1.13.1 Creating a user object
You can create a user object out of a single line or surface, or from any group which can contain lines,

surfaces and text.

To create a user object 

1. Right-click the group and select Save as object.

A dialog appears.

2. Select a category and fill out the other fields.
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3. When done, click OK.

The user object is added to the correct library in the User object libraries tab.

1.13.2 Managing user objects
To take a look at your user objects, open the User object libraries tab.

To update your user objects 

1. Make sure you have a working internet connection.
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2. In the User object libraries tab, click Download new items.

To open a library of user objects 

The items are ordered per scale, per manufacturer in alphabetical order.

Select a library to open it.

The user objects are displayed just like the regular track items.

NOTE: Your own objects have a blue border.

To share a user object 

If you’ve created an object you want to share, you can upload it to the AnyRail servers.

1. Right-click the object’s button and click Details .

2. Check the details one more time and click Share (upload).
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3. Please read the warning carefully before you click OK.

NOTE: Other people won’t see your objects right away - we have to approve them first.

1.14 Finishing up
Once you’ve completed the design, you’ll need to get it in some sort of usable form. It’s simplest just to print

the layout. However, you can also save parts of it as pictures – useful for emailing your friends or to publish

your track plan on a forum.

In addition, you can view lists of materials and sections.

1.14.1 Saving your work
You can save AnyRail design files just as you would with any other Windows software. You might also find

Save as useful for recording dif ferent stages of your design.

To save your file 

From the File tab, select Save.
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To save your file with a new name and location 

From the File tab, select Save As. A standard file window opens, allowing you to save a copy of your

file. The old one is untouched.

Auto-save 
AnyRail auto-saves your work every 10 minutes in a separate folder. If AnyRail closes in a normal way, these

auto-saved files (except for one) are deleted to preserve disk space.

In case your computer crashes, or if AnyRail terminates in an unexpected way, you can find a recent copy in

the Autosave folder.

To find an auto saved file 

1. Open the File tab.

2. Select Help.

3. Click the button tagged Autosave Folder.

NOTE: The most recent file you find is probably your best choice.

1.14.2 Print preview
Color ink is expensive! Also, it can be annoying to wait while a design prints out, only to discover that the

settings were not quite right. For this reason, AnyRail enables you to see what your printout is going to look

like.

To preview your printout 

From the File tab, click Print. AnyRail displays a preview of your printout.

1.14.3 Printing your design

To print your design 

1. From the File tab, select Print.

2. Review your settings and click the Print button.

The design prints at the specified scale, using several pages if required.

NOTE: Printing a large layout in a large scale takes a lot of processing power and resources. Each page is

a picture, so it might take a while depending on your computer.

TIP: To print your layout to real size, set the view scale to 1:1. However, before clicking OK, check the

number of pages it will take!
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1.14.4 Generating pictures
You can either create a picture of whatever is in view, or of the complete plan.

To generate pictures 

1. If required change the view scale. The scale slider is in the lower right corner of the status bar.

2. Use the scroll bars to get the exact picture you want if you need to crop the layout.

3. From the ribbon File tab, select Export As, then in the right pane, click Picture.

A window appears:

4.Click OK. A standard File window opens.

5.Save the file in the required graphics format.

WARNING: THIS IS NOT THE SAME AS SAVING YOUR TRACK PLAN! These pictures cannot be reloaded

into AnyRail.

1.14.5 Generating a 3D file
You can generate a 3D file that can be imported into most 3D drawing programs. The available formats are:

stl, dae, ply, 3ds, stp and obj.

To create a 3D File 

1. Open the File tab.

2. Select Export as.

3. Select 3D File.

4. Choose which categories you wish to export.

5. Type or select a file name, and press Save.

1.14.6 Generating a TrainPlayer file
You can generate an intermediate file that can be imported by TrainPlayer, a program that simulates running

trains on a layout. For more information, please go here.
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To create a TrainPlayer file 

1. Open the File tab.

2. Select Export as.

3. Select TrainPlayer export file.

4. Type or select a file name, and press Save.

1.14.7 Generating a list of materials
The list of materials contains all the track you’ve placed on the layout. It also shows the total track length,

and the track length per track element.

To generate a list of materials 

1. Open the Home tab.

2. Here, select List of materials .

The list of materials opens:

TIP: Copy and paste the list into a spreadsheet for further processing.

1.14.8 Generating a list of sections
The list of sections is very useful when assigning occupancy detectors.

To generate a list of sections 

1. Open the Home tab.
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2. Here, select List of sections.

The List of sections opens:

TIP: Copy and paste the list into your spreadsheet program for further processing.

1.15 Licensing
With the trial version, you can freely use AnyRail for small layouts of up to 50 elements.

If you want to go beyond that, you need to buy a license key that unlocks the software and lif ts this

restriction.

To register, first buy a license on our website.

You will immediately receive an email stating your registered user name and license key.

To register AnyRail 

1. Open the File tab, and click Register.
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2. Copy and paste the necessary information from your registration email.

NOTE: Make sure to enter both your registered name and the key exactly as these are stated in your

license details. Both need to match - including uppercase and lowercase letters and interpunction -

for the license to work.

3. Click OK.

NOTE: You may use your license on multiple computers, as long as you are the one using the software

yourself. The license may not be shared with others.

1.15.1 Updates and upgrades
Whether or not you have a license for AnyRail, you can always update your installation for free. Updates can

be recognized by a dif ference in the minor version number, e.g. 7.15.0 to 7.19.0, or in the patch number,

e.g. 7.15.0 to 7.15.1.

Upgrades can be recognized by a dif ference in the major version number, e.g. 7.27.0 to 8.1.0. Whether

upgrades are free depends on your current license.

To check the current license 

Open the File tab, and select Help.
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AnyRail indicates for which major versions your license is valid.

INFO: Of course, AnyRail will never overwrite an existing licensed version. If you install a newer version

for which you do not have a license, the new version will be installed next to the old version.

To check for updates and upgrades 

1. Open the File tab, and select Help.

2. Click Check for updates to find out if your version is current.

AnyRail automatically contacts us to see if a newer version is available. If so, it will ask you whether you want

to update.

Update options 
Depending on your settings, AnyRail regularly checks for updates automatically.

To view or change the update options 

1. Open the File tab, and select Help.

2. Click Update options.

2 Reference Guide
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This part of the user manual lists each AnyRail feature and function.

TIP: If you’re new to AnyRail, please read Getting Started first.

2.1 Features
This chapter lists those AnyRail features that need some extra explanation.

2.1.1 Glue
You can glue certain elements, such as track and predefined elements, so that you can’t accidentally move

them.

To glue track 

Right-click the element, and select Glue.

2.1.2 Rotate
Any element or selection of elements can be rotated.

Method 1 

1. Select the elements. A selection box with a handle appears.

2. Use the handle to rotate the selection with the mouse.

NOTE: If the handle is red, the selection cannot be rotated. Usually this is caused by glued items.

Method 2 

1. Select the elements. Depending on what you select, various extra tabs appear on the ribbon:

2. Click Rotate…

A new window appears:
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3. Enter an angle or use the slider. Your selection rotates as you change the angle. You can also use the

buttons to rotate a certain number of degrees. The 0 button resets the rotation to the start position.

4. Click OK.

NOTE: Using the slider will change the angle in full degrees. However, the angle may be changed an

arbitrary amount by entering a value in the edit box, i.e. 23.7.

2.1.3 Flip
Some elements can be flipped (i.e. turned into a mirror image of themselves). You can use this feature to

invert your complete layout if you wish. AnyRail will automatically replace each element with its mirrored

counterpart. AnyRail shows a list of elements that cannot be mirrored.

To flip an element or a selection of elements 

1. Select the elements to flip. For track, all connected track is flipped automatically when a subselection of

it is flipped.

2. In the ribbon, select Flip.

The elements are mirrored. If the action cannot be completed, a list of problem elements is displayed. These

elements don’t have a mirrored counterpart.

2.2 The Quick Access Toolbar (QAT)
The Quick Access Toolbar is the list with small icons at the top lef t of the window.
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Don’t worry if you can’t remember the small icons! If you hover over them you’ll see a tooltip.

To change to Quick Access Toolbar 

1. Right-click the function you want to add to the Quick Access Toolbar.

2. Select Add to Quick Access Toolbar.

Example 

Open the Show tab, right-click Roadbed and select Add to Quick Access Toolbar.

The function is added.

TIP: To reset AnyRail to its original settings, shut it down and start it again while holding SHIFT down.

2.3 The ribbon
All functions available in AnyRail can be accessed through the ribbon.

The ribbon is the part at the top of the window where the functions are displayed.

The ribbon is organized into tabs. A tab is organized into groups.

When you resize the AnyRail window, the ribbon resizes as well. Groups might collapse.
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To open a collapsed group, simply click the little arrow on it.

Sometimes, the ribbon takes too much space. To fold it, double-click one of its tabs (not the File tab).

Double-click a tab again to unfold it.

Tabs 
Not all tabs are visible at all times. The tabs to work on track, lines, rulers, etc. only appear when you have

selected these elements and are highlighted in green.

2.4 Ribbon Tab reference
In the following, each function on each tab is listed and explained.

2.4.1 File tab, 2D view
This in fact is not a real tab. It is the backstage button.

Click it to open.
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Function Description

New Start a new layout

Save Save the layout

Save As Save the layout by a new name

Open Open an existing layout from disk

3D View Switch to a 3D view

Info Info on your current design

Recent

designs
The files you have opened most recently

Print Print the layout or change print settings

Export as Export the layout in various formats

Help Help, updates, and registration

Options Program options

Exit Quit the program

Languages Change to another language

Register
Register the software with your license key. Only available when you’ve not already

registered
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Info 
Click Info to find these options.

Function Description

List of materials The list of all elements used in your track plan

List of sections The list of sections you defined for your track plan

List of labels The list of labels you gave to items, such as turnouts

Notes Your notes for this plan

Recent designs 
Click Recent designs to see the files you recently used.

Print 
Click Print to find these options.
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Function Description

Print Print the plan

Copies The number of copies to print

Portrait/Landscape The paper orientation

Suppress empty pages Do not print pages with nothing on it

Selection Print only what is selected in the plan

Print scale Set the print scale in various ways

Print alignment markers Print markers on the page corners to make it easier to align them

Print date/time and name Print this info on each page

Print page numbers Print a page number on each page

Print scale Print the scale on each page

Print Setup Setup printer, paper size, etc.

Export as 
Click the Export As button to find these options.
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Function Description

Picture Create a picture of your plan

PDF Create a PDF file

DXF Create a 2D export of the trace, that you could use for a laser cutter

3D File Create a 3D file that can be imported in most 3D viewers

Trainplayer

export file

Create a file that can be interpreted by Trainplayer. Trainplayer is a program to simulate

running trains that can be found here: Trainplayer

JMRI Layout

file
Creates a file that can be opened in JMRI PanelPro. More info is here: JMRI

Help 
Click the Help button to find these options.
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Function Description

Help Open this documentation

AnyRail

Website
Go to the AnyRail website

Options Open the options dialog

Autosave

folder

Open the folder with the automatically saved files. Use this function in case AnyRail

stopped or was stopped in an unexpected way, and you want to recover the layout you

were working on

Check

for

updates

Contact the AnyRail server and see if there are any updates

Update

options
Set the automatic update function

Register Register the software with a license key

Options 
This button opens a new window where you can set additional options.

General options 
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Function Description

Center work

area

Uncheck to draw the work area in the lef t upper corner of the screen. Check to

center the work area

Border width The border width when not having a centered work area

Rulers Side rulers

Width Side rulers width

Color scheme Overall color scheme

Show splash

screen
Show the logo while starting the program

Libraries 
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Select the scales for which you want to use the track and object libraries.

Colors 

Set the default colors for the various types of items. The slider is to change the transparency.

Texts 
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Set the text properties per category.

Languages 

Select your preferred language from the drop down box.

2.4.2 File tab, 3D view
This in fact is not a real tab. It is the backstage button.

Click it to open.
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Function Description

2D View Switch to the 2D design view

Help Help, updates, and registration

Exit Quit the program

2.4.3 Home tab, 2D view
The Home tab contains functions you probably use most often.
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Function Description

Cut Remove whatever’s selected, and keep it in the Paste buffer. Shortcut is Ctrl-X

Copy Keep a copy of whatever’s selected in the Paste buffer. Shortcut is Ctrl-C

Paste Paste whatever’s in the Paste buffer. Shortcut is Ctrl-V

Layers Open the layers pane

3D View Open the 3D view. This may take a few seconds for larger layouts

Open used libraries Open the libraries that are used by the current plan

Active Activate Search. Select from the drop down box to highlight the items in the plan

Combine flex Highlight all flexes with the same part number

View scale Set the display scale

Fit to window Find the largest scale such that the work area fits the window

List of materials Show a bill of materials

List of sections Show a list of all the isolated sections

List of labels Show a list of all the part labels

Notes Writing pad for your notes

Languages Change the program’s language

2.4.4 Home tab, 3D view
The Home tab contains functions you probably use most often.
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Function Description

2D View Open the 2D design view

Track Show the track

Ground Show the ground

Tunnels Show the tunnels

No sky/Blue

sky/Cloudy
Select a background

Use the standard camera

Use the FPS camera

Return the camera to its start position

Snapshot Make a snapshot

Lights
Set the brightness for each light. There is a light on each of the four corners, a top

light and an ambient light

Shadows Display shadows

2.4.5 Show tab
The Show tab contains functions to control what’s currently displayed.

Function Description

Centerline Show only a single line for the track

Track Show the track. The outer lines of what’s drawn are the actual rails

Detailed
Draw track with details. The sleepers have the actual width, but not the actual position

and distance from each other

Roadbed

Show the roadbed of the track. The actual width of the sectional elements is used here.

Make sure to tick this box if you want to check if the track fits on the baseboard, and

does not overlap

Trace Show a trace of the given Width under all track. This can be used to check clearances

Width Width of the trace

Hidden

track
Show all track labeled Hidden. This is dotted track in tunnels, hidden staging yards, etc.

Visible

track
Show all track not labeled Hidden. This is all track in plain sight

72



Track ends Show clear boundaries between the sectional track elements

Endpoints Show element endpoints

Connections Show connections between elements

Track

control

points

Show flex track control points

Flex too

long
When checked, overstretched flex appears red

Flex too

sharp

curves

When checked, too-tightly curved flex tracks appear red, orange and yellow

Inaccurate

connections
Mark connections that don’t fit perfectly with a red dot

Sections Show sections

Name
Show the name of the section. This only shows when there’s enough room. The software

determines a position and orientation for the text

Description Show the description of the section. This shows only when there’s enough room

Label Show the label for each part

Part

number

Show a part number on each track element. The software tries to scale the font down

on smaller parts. If this is not possible, the track number won’t show

Part code
Show a part code on each track element, if available. The software tries to scale the font

down on smaller parts. If this is not possible, the track code won’t show

Slope

percentages

This shows the percentage of the gradient (if any). 1% means one unit of descent/ascent

per 100 units of distance, e.g. 1 cm per meter. When the slope is too steep, this

percentage will be shown in red. See Settings to set the maximum slope

Height Show the heights

Vertical

clearance

Show the distance between the lower and upper track where tracks cross. Please note

that this is the top-rail to top-rail distance

Glue Show glue indicators

Reverse

loops
Show reverse loops. Only shows the shortest loops in case of multiple overlapping loops

Guides Show circle center point for curved track

Control

points
Show line and surface control points

Pages Show the pages as the layout would be printed in the current print scale

Objects Show predefined objects

User

objects
Show user objects

Function Description

73



Groups Show groups

Lines Show lines

Surfaces Show surfaces

Table tops Show table tops

Height

contours
Show height contours

-

Numbering
Numbering of the height contours

Texts Show texts

Rulers Show rulers

Tunnels Show tunnels

Lower limit
Only show all elements with a height of at least this value. Together with the Upper

limit, this allows you to define a horizontal slice of your layout

Upper limit Only show all elements with a height below this value

Function Description

2.4.6 Insert tab
On the Insert tab are elements that can be added to the layout.
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Function Description

Add line Add a line. You can use wider lines to draw streets or rivers

Add surface
Add a surface. This function can be used to draw shapes, the train table, or even

your garden

Add rectangle Add a rectangle with the given measurements

Width Width of the rectangle to add

Height Height of the rectangle to add

Add circle Add a circle with the given radius

Radius Radius of the circle to add

Add image Add an image

Free form Add a free form table top

Template Add a table top from a template

Module Add a module table top

Add height

contour
Add a height contour for landscaping

Add ruler Add a ruler. The length and style can be set af terwards

Add text Add text. The font and size can be set af terwards

2.4.7 Track libraries tab
On the Track libraries tab you can find all supported track libraries.

Note that the libraries are sorted by scale or gauge.

Click on the little down arrow to open a folded group (e.g. H0 in the picture).

Click a manufacturer’s name to get a list of the track systems we support.

TIP: Most people only use one gauge. To hide all gauges you are not going to use, go to the Options.

2.4.8 Object libraries tab
On the Object libraries tab you can find all the predefined objects, such as signals, trees, and structures.
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The icon indicates the sort of objects that you’ll find.

Click the small arrow to open the list of supported libraries.

TIP: Most people only use one gauge. To hide all gauges you are not going to use, go to the Options.

2.4.9 User object libraries tab
On the User object libraries tab you can manage your user objects.

The items are ordered per scale, per manufacturer in alphabetical order.

Click Download new items to download items that others have shared.

Viewer 

1. Click Viewer to view all the items:

2. Click the Load button to populate the viewer.

3. Use the Filter to find items.
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2.4.10 Settings tab
Use the Settings tab to change the overall settings of the software.

AnyRail remembers settings between sessions, but also saves them with each layout.
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Function Description

Measurement

system
Choose from cm, mm, inches with fractions or decimals

Decimals Set the display accuracy of all values

Length The length of the work area on screen. Make it somewhat larger than your train table

Width The width of the work area on screen. Make it somewhat larger than your train table

Grid Show a grid with a Size, possibly in the Background

Endpoint The drawing size of an endpoint. An endpoint is the outer end of a piece of track

Connection
The drawing size of a connection. The connection is the circle denoting that two pieces

of track are connected

Control point
The drawing size of the control points. These are the points to manipulate flex track

and lines

Minimum

radius 1

Radius 1 used for determining when Flex too sharp curves triggers, indicated by a red

centerline

Minimum

radius 2
Radius 2, 0 (inactive) or larger than radius 1, indicated by an orange centerline

Minimum

radius 3
Radius 3, 0 (inactive) or larger than radius 2, indicated by a yellow centerline

Distance The maximum distance allowed allowed between connecting endpoints

Angle The maximum angle allowed between connecting endpoints

Maximum % The maximum percentage allowed on slopes

Min. vertical

clearance
The minimum vertical distance allowed for track crossings

Autoconnect Automatically connect track when endpoints are close enough

Distance The minimum distance to make Autoconnect trigger

Allow mixed

rails

When checked, any track with the same gauge will connect. Uncheck to make sure you

use the correct transition track

Snap to grid
Makes lines and surfaces snap to an underlying grid with Size. The lef t upper point of

the line or surface is aligned with the grid

2.5 Context sensitive tabs and popup menus
Some tabs only display in specific cases, depending on what you’ve currently selected on screen.

These tabs have a green glow.

When you right-click an object, a popup menu comes up, giving you fast access to the most frequently used

features.
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2.5.1 Track tab and menu
The Track tab appears when track is selected.

The track popup menu appears when you right-click the track.

Function Description

Delete Delete the selected track

Glue Glue the selected track to prevent accidentally moving it

Rotate… Rotate the selected track and all connected track with it

Flip Mirror all selected track with all connected track

Elevate… Increase or decrease the height of the selected track

Layer Move selected track to another layer

Send to back Send this track to the back of all elements with the same height

Send backward Send this track one step back relative to all elements with the same height

Bring to front Bring this track on top of all the elements with the same height

Bring forward
Bring this track one step further to the top relative to all elements with the same

height

Standard The track is displayed as-is, both in 2D and 3D

Hidden
The track is displayed as a dotted line in 2D. In 3D, it will be hidden, and a tunnel is

created if necessary

Embankment
In 2D, small lines indicate that the track is on an embankment. In 3D, the ground is

shaped as an embankment

Bridge In 2D, trellis is drawn over the bridge. In 3D, the track is put on pillars
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Extend

selection
Enlarge the selection in a logical way. Double click on the track has the same result

Select section Only when sections are used: select the complete section

Select stretch Select all connected track

Disconnect Disconnect the selected track

Add isolators Insert isolators at the outer ends of the current selection

Remove

isolators
Remove all isolators in the current selection

Change

direction
For single track only: add an arrow to indicate one way track

Cut… Cut the track in two. Only for simple curves and straights

Cut here Cut the track at the mouse position

Cut and

connect here
Cut and connect the track at the mouse position

Lock height Lock the heights for the endpoints of the track

Set height… Set the height of the selected track

Smooth slope Create a slope for the selected track

Create helix… Create a helix from the currently selected, unconnected curve

Label Set a label for the selected track element

Create section Turn the selection, or isolated track, into a section

Search this part Highlight all the same parts in the plan

Details Show details and positions of the selected track

Function Description

Section functions 
Whenever a section is defined for the selected track, the tab has a few additional functions.

Function Description

Remove sections Remove the section definitions. The track itself is not removed

Name Enter a name for the section here

Description Select or enter a description here

Color Select a color for the section
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2.5.2 Endpoint tab and menu
Clicking on an endpoint (the small line and triangle at the end of the track) reveals the Endpoint tab.

The endpoint popup menu appears when you right-click an endpoint.

Function Description

Lock

height

Lock the height so it cannot be changed by accident. Be careful using this function and

make sure that you check the heights surrounding it to confirm the slopes are all OK

Create

slope…
Create a slope with a certain percentage

Height The height of this point

x The x coordinate of this point

y The y coordinate of this point

Direction(º) The direction of the endpoint

Connect Connect this endpoint to a nearby other endpoint

2.5.3 Connection tab and menu
Clicking on a connection (the small circle between two pieces of track) reveals the Connection tab.

The connection popup menu appears when you right-click a connection.
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Function Description

Lock height
Lock the height so it cannot be changed by accident. Be careful using this function and

make sure that you check the heights surrounding it to confirm the slopes are all OK

Create

slope…
Create a slope with a certain percentage

Height The height of the connection

x The x coordinate of the connection

y The y coordinate of the connection

Direction (º) The direction of the connection

Disconnect Remove the connection and disconnect the track

Add/Remove

isolator

Adds or removes the isolator between the two pieces of track. Use this to create

sections

2.5.4 Lines tab and menu
The Lines tab is only available when a line or one of its points is selected.

The popup menu is available when you right-click a point or a line.

Point functions 
Outer point tab

Outer point popup menu

Inner point tab

Inner point popup menu
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Function Description

x The x coordinate of this point

y The y coordinate of this point

Move point Move only this point

Move line Move the whole line

Normal corner The corner defined by the neighboring points

Round corner A perfect arc

Curved corner An elliptic corner

Delete point Delete the current point

Add point Add a point close to the current point

End styles Select an end style

Size End style size

Resume drawing Continue to draw a line from here

Cut here Cut the line in two

Line functions 
Tab

Popup menu
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Function Description

Delete Delete the line

Glue Glue the line to avoid moving it by accident

Rotate… Rotate the line

Flip Mirror the line

Elevate… Increase or decrease the height

Layer Select to move the lined to another layer

Send to back Send this line to the back of all elements with the same height

Send backward Send this line one step back relative to all elements with the same height

Bring to front Bring this line on top of all the elements with the same height

Bring forward
Bring this line one step further to the top relative to all elements with the same

height

Line width Set the drawing width of the line

Height Set the height of the line. A line has one height, it can not be tilted

Background Put this line in the background

Line color Set the drawing color of the line

Transparency Slide to set the transparency of the line

Rounded

points
Round the points (for larger line widths)

Normal corners Set all corners to normal

Round corners Set all corners to perfect arcs

Curved corners Set all corners to elliptical curves

Dashed Create a dashed line with dash lengths Dash A and Dash B

Save as object Create a user object from the selected lines

Add point Add point at cursor

2.5.5 Surfaces tab and menu
The Surfaces tab is only available when a surface, or one of its points is selected.

The popup menu is available when you right-click a point or a surface.

Point functions 
Tab
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Popup menu

Function Description

x The x coordinate of this point

y The y coordinate of this point

Move point Move only this point

Move surface Move the whole surface

Normal corner The corner defined by the neighboring points

Round corner A perfect arc

Curved corner An elliptic corner

Delete point Delete the current point

Add point Add a point close to the current point

Surface functions 
Tab

Popup menu
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Function Description

Delete Delete the surface

Glue Glue the surface to avoid moving it by accident

Rotate… Rotate the surface

Flip Mirror the surface

Elevate Increase or decrease the height

Layer Select to move the surface to another layer

Send to back Send this surface to the back of all elements with the same height

Send backward Send this surface one step back relative to all elements with the same height

Bring to front Bring this surface on top of all the elements with the same height

Bring forward
Bring this surface one step further to the top relative to all elements with the

same height

Line width Set the drawing width of the outline

Height Set the height of the surface. A surface has one height, it can not be tilted

Background Put this surface in the background

Line color Set the drawing color of the line

Fill color Set the fill color of the surface

Transparency Slide to set the transparency of the surface

Normal corners Set all corners to normal

Round corners Set all corners to perfect arcs

Curved corners Set all corners to elliptical curves

Rounded points Round the points (for larger outline widths)

Convert to table top Convert the surface into a free form table top

Convert to height

contour
Convert the surface into a height contour

Save as object Create a user object from the selected surfaces

Load image Load an image to fill the surface

Remove image Remove the image that fills the surface

Width, Height, Angle Set the size of the image (in your measurement units), and the orientation

Maintain aspect ratio Keep the aspect ratio of the original image

Follow outline Image follows resizing of surface. Surface should be rectangular

Adjust outline Recalculates the surface outline so it fits the picture exactly
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2.5.6 Rulers tab and menu
The Rulers tab appears when a ruler or one of it endpoints is selected.

Apart from simply dragging its endpoints, you can either click the ruler or one of its endpoints to manipulate

it.

Ruler point 
Tab:

The ruler point does not have a popup menu.

Function Description

x The x coordinate of this point

y The y coordinate of this point

Move point Move only this endpoint of the ruler

Move ruler Move the whole ruler

Ruler 
Tab

Popup menu
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Function Description

Delete Delete the ruler

Glue Glue the ruler to avoid accidentally moving it

Rotate… Rotate the ruler

Flip Mirror the ruler

Elevate Increase or decrease the height

Layer Move the ruler to another layer

Horizontal Position the ruler horizontally. Click again to put it upside down

Vertical Position the ruler vertically. Click again to put it the other way around

Length Set the length of the ruler

Scale The scale of the ruler. The displayed length is relative to the modeling scale

Height Height of the ruler

Change style Change the way the ruler looks

Font Set the font of the ruler text

Size Set the font size of the ruler text

Line width Ruler line width

Line color Color of the ruler

2.5.7 Texts tab and menu
The Texts tab appears only when text is selected.

The text popup menu appears when you right-click the text.
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Function Description

Delete Delete selected text

Glue Glue selected text to avoid accidentally moving it

Rotate Rotate the selected text

Flip Mirror the selected text

Elevate Increase or decrease the height

Layer Select a layer for the text

Horizontal Position the text horizontally. Click twice to position the text upside down

Vertical Position the text vertically. Click twice to position it the other way around

Color Set a color for the selected text

Font Select a font

Size Select a font size

x The x position of the text

y The y position of the text

Height Draw height of the text

Edit text Click to edit the text. This can also be achieved by double clicking the text

TIP: Quickly start editing text by double-clicking it.

2.5.8 Selection tab
The Selection tab is only available when multiple items are selected.
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Function Description

Delete Delete the selected items

Glue Glue the selected items to avoid moving it by accident

Rotate… Rotate the selected items

Flip Mirror the selected items

Elevate Increase or decrease the height of everything in the selection

Layer Select to move the selected items to another layer

Send to back Send selected items to the back of all elements with the same height

Send

backward
Send selected items one step back relative to all elements with the same height

Bring to front Bring selected items on top of all the elements with the same height

Bring forward
Bring selected items one step further to the top relative to all elements with the same

height

2.5.9 Groups tab and menu
The Groups tab is only available when multiple groupable items are selected, or a group.

The group popup menu appears when you right-click the group.
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Function Description

Delete Delete the group

Glue Glue the group to avoid moving it by accident

Rotate… Rotate the group

Flip Mirror the group

Elevate Increase or decrease the height

Layer Select to move the group to another layer

Send to back Send this group to the back of all elements with the same height

Send

backward
Send this group one step back relative to all elements with the same height

Bring to front Bring this group on top of all the elements with the same height

Bring forward
Bring this group one step further to the top relative to all elements with the same

height

Group Group selected lines and groups (only available when applicable)

Ungroup Ungroup this group (only available when applicable)

x The lef t top x coordinate of the group

y The lef t top y coordinate of the group

Height Draw height of the group

Description Description for the group (only available when applicable)

Save as object Create a user object from the group

92


	AnyRail 7 manual
	Table of contents
	1 Getting Started
	1.1 Setting up
	1.1.1 Choosing a measurement system
	To specify a measurement system #

	1.1.2 Specifying a work area size
	To specify a work area size #

	1.1.3 Creating a table top
	To add a table top #

	1.1.4 View drawing scale
	To zoom in or zoom out #

	1.2 Track Libraries
	1.2.1 Opening a track library
	To open a Track Library #

	1.2.2 Browsing a track library
	To browse a track library #

	1.2.3 Closing a track library
	To close a Track Library #

	1.3 Docking and undocking a library window
	To dock a Library window #
	To undock a Library window #

	Nesting libraries #
	1.4 Working with track
	1.4.1 Adding track
	To add a track Piece #

	1.4.2 Track appearance
	Example 1: Centerline #
	Example 2: Track #
	Example 3: Detailed #
	Example 4: Centerline with roadbed #

	1.4.3 Track build style
	Standard #
	Hidden #
	Embankment #
	Bridge #

	1.4.4 Moving and connecting track
	To connect track #

	1.4.5 Disconnecting track
	To disconnect an endpoint using the popup menu #
	To disconnect an endpoint using the ribbon #
	To disconnect the track using the popup menu #
	To disconnect the track using the ribbon #

	1.4.6 Selecting track
	To select track #

	Other ways to select or deselect pieces #
	CTRL + click each piece #
	Double-click a piece to extend the selection #
	Triple-click to select all connected track #
	SHIFT-click to extend the selection #
	To deselect a single piece #
	To deselect all the pieces #

	1.4.7 Gluing track
	To glue track #

	1.4.8 Turntables
	1.4.9 Closing gaps
	To close a gap #

	1.4.10 Creating a helix
	To create a helix #

	1.5 Flex track
	1.5.1 Basic Handling
	To connect flex track #

	1.5.2 Curves, straights and easements from flex
	To create a straight, curve or easement #

	1.5.3 Parallel flex track
	To create parallel track #

	1.6 The ribbon and the popup menu
	The ribbon #
	The popup menu #

	1.7 Pieces, stretches and sections
	Pieces and stretches #
	Sections #

	1.7.1 Working with sections
	Method 1: Creating a section from selected track #
	Method 2: Creating a section from isolated track #
	To change a section’s properties #
	To change a section’s color #

	1.8 Working with height
	1.8.1 Displaying heights
	To display heights #

	1.8.2 Specifying heights
	To set selected track to a certain height #
	To specify a height for a point #
	To create a slope #
	To create a smooth slope #
	To set the maximum percentage for slopes #

	1.9 The status bar
	To customize the status bar #

	1.10 More than just track
	1.10.1 Adding lines and surfaces
	To add a line #
	To add a surface #
	To add a point to the line or surface #
	To delete a point #
	To move a point #
	To position a point #
	To create round corners #

	1.10.2 Manipulating surfaces
	To move a line #
	To resize the shape #

	1.10.3 Adding text
	To add text #
	To change the appearance #
	To edit existing text #
	To move the text #

	1.10.4 Adding rulers
	To add a ruler #
	To change the appearance #
	To move the ruler #

	1.10.5 Predefined elements
	Scenery elements #
	Signals #
	Structures #

	1.10.6 Groups
	To create a group #

	1.11 Layers
	1.11.1 The Layers pane
	To add a layer #
	To remove a layer #
	To rename a layer #
	To make a layer visible or invisible #
	To lock a layer #

	1.11.2 Moving objects to another layer
	To move objects to another layer #

	1.12 3D Viewer
	To go to the 3D View #

	1.12.1 Navigating
	Standard camera #
	To navigate #

	FPS camera #
	To navigate #

	1.12.2 Lights
	1.12.3 Snapshot
	To make a snapshot #

	1.13 User objects
	1.13.1 Creating a user object
	To create a user object #

	1.13.2 Managing user objects
	To update your user objects #
	To open a library of user objects #
	To share a user object #

	1.14 Finishing up
	1.14.1 Saving your work
	To save your file #
	To save your file with a new name and location #

	Auto-save #
	To find an auto saved file #

	1.14.2 Print preview
	To preview your printout #

	1.14.3 Printing your design
	To print your design #

	1.14.4 Generating pictures
	To generate pictures #

	1.14.5 Generating a 3D file
	To create a 3D File #

	1.14.6 Generating a TrainPlayer file
	To create a TrainPlayer file #

	1.14.7 Generating a list of materials
	To generate a list of materials #

	1.14.8 Generating a list of sections
	To generate a list of sections #

	1.15 Licensing
	To register AnyRail #

	1.15.1 Updates and upgrades
	To check the current license #
	To check for updates and upgrades #

	Update options #
	To view or change the update options #

	2 Reference Guide
	2.1 Features
	2.1.1 Glue
	To glue track #

	2.1.2 Rotate
	Method 1 #
	Method 2 #

	2.1.3 Flip
	To flip an element or a selection of elements #

	2.2 The Quick Access Toolbar (QAT)
	To change to Quick Access Toolbar #

	2.3 The ribbon
	Tabs #
	2.4 Ribbon Tab reference
	2.4.1 File tab, 2D view
	Info #
	Recent designs #
	Print #
	Export as #
	Help #
	Options #
	General options #
	Libraries #
	Colors #
	Texts #
	Languages #

	2.4.2 File tab, 3D view
	2.4.3 Home tab, 2D view
	2.4.4 Home tab, 3D view
	2.4.5 Show tab
	2.4.6 Insert tab
	2.4.7 Track libraries tab
	2.4.8 Object libraries tab
	2.4.9 User object libraries tab
	Viewer #

	2.4.10 Settings tab
	2.5 Context sensitive tabs and popup menus
	2.5.1 Track tab and menu
	Section functions #
	2.5.2 Endpoint tab and menu
	2.5.3 Connection tab and menu
	2.5.4 Lines tab and menu
	Point functions #
	Line functions #
	2.5.5 Surfaces tab and menu
	Point functions #
	Surface functions #
	2.5.6 Rulers tab and menu
	Ruler point #
	Ruler #
	2.5.7 Texts tab and menu
	2.5.8 Selection tab
	2.5.9 Groups tab and menu

